Tuesday maintenance window. Windows updates and security patches

Resolved

This incident is resolved.
Posted Apr 01, 2026 - 11:14 EDT

Identified

We've identified the issue.
Posted Apr 01, 2026 - 11:14 EDT

Investigating

Windows updates and patches will be applied in a a planned maintenance window every second Tuesday of each month. The maintenance window will occur from 5 AM - 7:45 AM.

All Windows servers are affected and could be unavailable during this planned window.
Posted Apr 01, 2026 - 11:13 EDT
This incident affected: Infrastructure & Hosting (VMware Services).